Cross-site Scripting (XSS) in @scullyio/scully
CVE-2020-28470GHSA-r96p-v3cr-gfv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@scullyio/scully 1.0.9; @scullyio/ng-lib 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @scullyio/scully
- Affected
- < 1.0.9
- Fixed in
- 1.0.9
npm @scullyio/ng-lib
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r96p-v3cr-gfv8 lists affected ranges: npm @scullyio/scully >=0 =0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r96p-v3cr-gfv8 lists affected ranges: npm @scullyio/scully >=0 =0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2020-28470: 0.83% estimated exploitation activity in the next 30 days; percentile 57.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package @scullyio/scully before 1.0.9. The transfer state is serialised with the JSON.stringify() function and then written into the HTML page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r96p-v3cr-gfv8
- Revision 1 · created ·
Published from osv record GHSA-r96p-v3cr-gfv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-28470 Advisory: Cross-site Scripting (XSS) in @scullyio/scully IDs: CVE-2020-28470, GHSA-r96p-v3cr-gfv8 Record: https://patchnext.com/advisories/cve-2020-28470 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @scullyio/scully 1.0.9; @scullyio/ng-lib 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @scullyio/scully: affected < 1.0.9; fixed in 1.0.9 - npm @scullyio/ng-lib: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls @scullyio/scully --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @scullyio/ng-lib --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @scullyio/scully, @scullyio/ng-lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r96p-v3cr-gfv8 (OSV record GHSA-r96p-v3cr-gfv8 lists affected ranges: npm @scullyio/scully >=0 =0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-r96p-v3cr-gfv8 (GitHub-reviewed advisory GHSA-r96p-v3cr-gfv8 lists affected ranges: npm @scullyio/scully >=0 =0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…