Stored XSS vulnerability in Jenkins Active Choices Plugin
CVE-2020-2289GHSA-9jv5-wf44-8vfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.biouno:uno-choice 2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.biouno:uno-choice
- Affected
- < 2.5
- Fixed in
- 2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jv5-wf44-8vfm lists affected ranges: Maven org.biouno:uno-choice >=0 <2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-2289: 0.91% estimated exploitation activity in the next 30 days; percentile 60.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Active Choices Plugin 2.4 and earlier does not escape the name and description of build parameters. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. Active Choices Plugin 2.5 escapes the name of build parameters and applies the configured markup formatter to the description of build parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9jv5-wf44-8vfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-2289 Advisory: Stored XSS vulnerability in Jenkins Active Choices Plugin IDs: CVE-2020-2289, GHSA-9jv5-wf44-8vfm Record: https://patchnext.com/advisories/cve-2020-2289 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.biouno:uno-choice 2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.biouno:uno-choice: affected < 2.5; fixed in 2.5 ## Suggested inspection (read-only) - Maven org.biouno:uno-choice: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.biouno:uno-choice. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9jv5-wf44-8vfm (GitHub-reviewed advisory GHSA-9jv5-wf44-8vfm lists affected ranges: Maven org.biouno:uno-choice >=0 <2.5) Commands are suggestions: review each one before running it.
Loading voting…