Skip to content

← Actionable
Critical, CVSS 9.8

liufee CMS File Upload vulnerability

CVE-2020-21174GHSA-q3q5-qvh5-cmw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (feehi/cms 2.0.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist feehi/cms

    Affected
    < 2.0.8.1
    Fixed in
    2.0.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-21174: 1.31% estimated exploitation activity in the next 30 days; percentile 70.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

File Upload vulnerability in liufee CMS v.2.0.7.1 allows a remote attacker to execute arbitrary code via the image suffix function.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q3q5-qvh5-cmw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-21174

Advisory: liufee CMS File Upload vulnerability
IDs: CVE-2020-21174, GHSA-q3q5-qvh5-cmw5
Record: https://patchnext.com/advisories/cve-2020-21174 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: feehi/cms 2.0.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist feehi/cms: affected < 2.0.8.1; fixed in 2.0.8.1

## Suggested inspection (read-only)
- Packagist feehi/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on feehi/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q3q5-qvh5-cmw5 (GitHub-reviewed advisory GHSA-q3q5-qvh5-cmw5 lists affected ranges: Packagist feehi/cms >=0 <2.0.8.1)

Commands are suggestions: review each one before running it.

Loading voting…