Skip to content

← Actionable
High, CVSS 7.5amended

Improper Key Verification in openpgp

CVE-2019-9154GHSA-hfmf-q43v-2ffj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openpgp 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openpgp

    Affected
    <= 4.1.2
    Fixed in
    4.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2019-9154: 1.62% estimated exploitation activity in the next 30 days; percentile 76.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of openpgp prior to 4.2.0 are vulnerable to Improper Key Verification. The OpenPGP standard allows signature packets to have subpackets which may be hashed or unhashed. Unhashed subpackets are not cryptographically protected and cannot be trusted. The openpgp package does not verify whether a subpacket is hashed. Furthermore, due to the order of parsing a signature packet information from unhashed subpackets overwrites information from hashed subpackets. This may allow an attacker to modify the contents of a key certification signature or revocation signature. Doing so could convince a victim to use an obsolete key for encryption. An attack require a victim to import a manipulated key or update an existing key with a manipulated version. Recommendation Upgrade to version 4.2.0 or later. If you are upgrading from a version <4.0.0 it is highly recommended to read the High-Level API Changes section of the openpgp 4.0.0 release:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hfmf-q43v-2ffj

  2. Revision 1 · created ·

    Published from osv record GHSA-hfmf-q43v-2ffj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-9154

Advisory: Improper Key Verification in openpgp
IDs: CVE-2019-9154, GHSA-hfmf-q43v-2ffj
Record: https://patchnext.com/advisories/cve-2019-9154 (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openpgp 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openpgp: affected <= 4.1.2; fixed in 4.2.0

## Suggested inspection (read-only)
- `npm ls openpgp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openpgp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hfmf-q43v-2ffj (OSV record GHSA-hfmf-q43v-2ffj lists affected ranges: npm openpgp >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hfmf-q43v-2ffj (GitHub-reviewed advisory GHSA-hfmf-q43v-2ffj lists affected ranges: npm openpgp >=0 <=4.1.2)

Commands are suggestions: review each one before running it.

Loading voting…