Use after free in image
CVE-2019-16138GHSA-m2pf-hprp-3vqm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (image 0.21.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io image
- Affected
- >= 0.10.2, < 0.21.3
- Fixed in
- 0.21.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2pf-hprp-3vqm lists affected ranges: crates.io image >=0.10.2 <0.21.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-16138: 2.48% estimated exploitation activity in the next 30 days; percentile 84.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of this crate would call Vec::setlen on an uninitialized vector with user-provided type parameter, in an interface of the HDR image format decoder. They would then also call other code that could panic before initializing all instances. This could run Drop implementations on uninitialized types, equivalent to use-after-free, and allow an attacker arbitrary code execution. Two different fixes were applied. It is possible to conserve the interface by ensuring proper initialization before calling Vec::setlen. Drop is no longer called in case of panic, though. Starting from version 0.22, a breaking change to the interface requires callers to pre-allocate the output buffer and pass a mutable slice instead, avoiding all unsafe code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m2pf-hprp-3vqm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-16138 Advisory: Use after free in image IDs: CVE-2019-16138, GHSA-m2pf-hprp-3vqm Record: https://patchnext.com/advisories/cve-2019-16138 (revision 1, source checked 26 Oct 2026, 15:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: image 0.21.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io image: affected >= 0.10.2, < 0.21.3; fixed in 0.21.3 ## Suggested inspection (read-only) - crates.io image: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on image. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m2pf-hprp-3vqm (GitHub-reviewed advisory GHSA-m2pf-hprp-3vqm lists affected ranges: crates.io image >=0.10.2 <0.21.3) Commands are suggestions: review each one before running it.
Loading voting…