django-ucamlookup Cross-site Scripting vulnerability
CVE-2016-15010GHSA-pjx4-3f3p-29v3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django-ucamlookup 1.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django-ucamlookup
- Affected
- < 1.9.2
- Fixed in
- 1.9.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjx4-3f3p-29v3 lists affected ranges: PyPI django-ucamlookup >=0 <1.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjx4-3f3p-29v3 lists affected ranges: PyPI django-ucamlookup >=0 <1.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2016-15010: 0.58% estimated exploitation activity in the next 30 days; percentile 47.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability classified as problematic was found in University of Cambridge django-ucamlookup up to 1.9.1. Affected by this vulnerability is an unknown functionality of the component Lookup Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.9.2 can address this issue. The name of the patch is 5e25e4765637ea4b9e0bf5fcd5e9a922abee7eb3. It is recommended to upgrade the affected component. The identifier VDB-217441 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pjx4-3f3p-29v3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pjx4-3f3p-29v3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-15010 Advisory: django-ucamlookup Cross-site Scripting vulnerability IDs: CVE-2016-15010, GHSA-pjx4-3f3p-29v3 Record: https://patchnext.com/advisories/cve-2016-15010 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django-ucamlookup 1.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django-ucamlookup: affected < 1.9.2; fixed in 1.9.2 ## Suggested inspection (read-only) - `python -m pip show django-ucamlookup`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django-ucamlookup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjx4-3f3p-29v3 (OSV record GHSA-pjx4-3f3p-29v3 lists affected ranges: PyPI django-ucamlookup >=0 <1.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pjx4-3f3p-29v3 (GitHub-reviewed advisory GHSA-pjx4-3f3p-29v3 lists affected ranges: PyPI django-ucamlookup >=0 <1.9.2) Commands are suggestions: review each one before running it.
Loading voting…