Skip to content

← Actionable
High, CVSS 8.7amended

Forgeable Public/Private Tokens in jws

CVE-2016-1000223GHSA-gjcw-v447-2w7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jws 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jws

    Affected
    < 3.0.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions of the jws package allow users to select what algorithm the server will use to verify a provided JWT. A malicious actor can use this behaviour to arbitrarily modify the contents of a JWT while still passing verification. For the common use case of the JWT as a bearer token, the end result is a complete authentication bypass with minimal effort. Recommendation Update to version 3.0.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gjcw-v447-2w7q

  2. Revision 1 · created ·

    Published from osv record GHSA-gjcw-v447-2w7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-1000223

Advisory: Forgeable Public/Private Tokens in jws
IDs: CVE-2016-1000223, GHSA-gjcw-v447-2w7q
Record: https://patchnext.com/advisories/cve-2016-1000223 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jws 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jws: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `npm ls jws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jws.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gjcw-v447-2w7q (OSV record GHSA-gjcw-v447-2w7q lists affected ranges: npm jws >=0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gjcw-v447-2w7q (GitHub-reviewed advisory GHSA-gjcw-v447-2w7q lists affected ranges: npm jws >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…