Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks
CVE-2015-5175GHSA-3357-829x-m9pr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cxf.fediz:fediz-idp 1.2.1, 1.1.3; org.apache.cxf.fediz:fediz-core 1.2.1, 1.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cxf.fediz:fediz-idp
- Affected
- < 1.1.3>= 1.2, < 1.2.1
- Fixed in
- 1.1.3, 1.2.1
Maven org.apache.cxf.fediz:fediz-core
- Affected
- < 1.1.3>= 1.2, < 1.2.1
- Fixed in
- 1.1.3, 1.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3357-829x-m9pr lists affected ranges: Maven org.apache.cxf.fediz:fediz-idp >=0 =1.2 =0 =1.2 <1.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2015-5175: 10.90% estimated exploitation activity in the next 30 days; percentile 95.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Application plugins in Apache CXF Fediz prior to version 1.1.3 and 1.2.x prior to 1.2.1 allow remote attackers to create a denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3357-829x-m9pr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-5175 Advisory: Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks IDs: CVE-2015-5175, GHSA-3357-829x-m9pr Record: https://patchnext.com/advisories/cve-2015-5175 (revision 1, source checked 26 Oct 2026, 16:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cxf.fediz:fediz-idp 1.2.1, 1.1.3; org.apache.cxf.fediz:fediz-core 1.2.1, 1.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cxf.fediz:fediz-idp: affected < 1.1.3; >= 1.2, < 1.2.1; fixed in 1.1.3, 1.2.1 - Maven org.apache.cxf.fediz:fediz-core: affected < 1.1.3; >= 1.2, < 1.2.1; fixed in 1.1.3, 1.2.1 ## Suggested inspection (read-only) - Maven org.apache.cxf.fediz:fediz-idp: check the installed version with your package manager. - Maven org.apache.cxf.fediz:fediz-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cxf.fediz:fediz-idp, org.apache.cxf.fediz:fediz-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3357-829x-m9pr (GitHub-reviewed advisory GHSA-3357-829x-m9pr lists affected ranges: Maven org.apache.cxf.fediz:fediz-idp >=0 =1.2 =0 =1.2 <1.2.1) Commands are suggestions: review each one before running it.
Loading voting…