Skip to content

← Actionable
Critical, CVSS 9.3amended

Improper Authentication in requests-kerberos

CVE-2014-8650GHSA-wh37-37xw-54hr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests-kerberos 0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2014-8650: 3.65% estimated exploitation activity in the next 30 days; percentile 89.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

python-requests-Kerberos through 0.5 does not handle mutual authentication

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wh37-37xw-54hr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wh37-37xw-54hr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-8650

Advisory: Improper Authentication in requests-kerberos
IDs: CVE-2014-8650, GHSA-wh37-37xw-54hr
Record: https://patchnext.com/advisories/cve-2014-8650 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: requests-kerberos 0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI requests-kerberos: affected < 0.6; fixed in 0.6

## Suggested inspection (read-only)
- `python -m pip show requests-kerberos`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on requests-kerberos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wh37-37xw-54hr (OSV record GHSA-wh37-37xw-54hr lists affected ranges: PyPI requests-kerberos >=0 <0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-wh37-37xw-54hr (GitHub-reviewed advisory GHSA-wh37-37xw-54hr lists affected ranges: PyPI requests-kerberos >=0 <0.6)

Commands are suggestions: review each one before running it.

Loading voting…