Moderate severity vulnerability that affects Products.PlonePAS
CVE-2009-0662GHSA-pq3x-96c3-xgjg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (products-plonepas 3.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI products-plonepas
- Affected
- >= 3, < 3.9
- Fixed in
- 3.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pq3x-96c3-xgjg lists affected ranges: PyPI products-plonepas >=3 <3.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pq3x-96c3-xgjg lists affected ranges: PyPI products-plonepas >=3 <3.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-0662: 0.97% estimated exploitation activity in the next 30 days; percentile 61.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PlonePAS product 3.x before 3.9 and 3.2.x before 3.2.2, a product for Plone, does not properly handle the login form, which allows remote authenticated users to acquire the identity of an arbitrary user via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pq3x-96c3-xgjg
- Revision 1 · created ·
Published from osv record GHSA-pq3x-96c3-xgjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-0662 Advisory: Moderate severity vulnerability that affects Products.PlonePAS IDs: CVE-2009-0662, GHSA-pq3x-96c3-xgjg Record: https://patchnext.com/advisories/cve-2009-0662 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: products-plonepas 3.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI products-plonepas: affected >= 3, < 3.9; fixed in 3.9 ## Suggested inspection (read-only) - `python -m pip show products-plonepas`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on products-plonepas. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pq3x-96c3-xgjg (OSV record GHSA-pq3x-96c3-xgjg lists affected ranges: PyPI products-plonepas >=3 <3.9 (fixed)) - Verified: https://github.com/advisories/GHSA-pq3x-96c3-xgjg (GitHub-reviewed advisory GHSA-pq3x-96c3-xgjg lists affected ranges: PyPI products-plonepas >=3 <3.9) Commands are suggestions: review each one before running it.
Loading voting…