High, CVSS 7.5PyPIPublished
zstd vulnerable to buffer overrun
CVE-2022-4899 · GHSA-5c9c-6x87-f9vm
- Affected
- PyPI zstd < 1.5.4.0
- Fixed in
- 1.5.4.0· Vendor fix available
- Issue
- A vulnerability was found in zstd v1.4.10, where an attacker can supply an empty string as an argument to the command line tool to cause buffer overrun.
Recommended action: Upgrade to 1.5.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.