Critical, CVSS 9.8PyPIAmendedPublished
xalpha vulnerable to Remote Code Execution
CVE-2023-37659 · GHSA-jx3q-5rgf-vrrr
- Affected
- PyPI xalpha >= 0.11.4, < 0.11.9
- Fixed in
- 0.11.9· Vendor fix available
- Issue
- xalpha v0.11.4 is vulnerable to Remote Command Execution (RCE). User input is not properly checked to be numerical values prior to being evaluated.
Recommended action: Upgrade to 0.11.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.