Skip to content

← Public intelligence

PyPI package

vtk

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PyPIPublished

    PYSEC-2025-226

    CVE-2025-57108

    Affected
    • PyPI vtk < 9.5.1
    Fixed in
    9.5.1· Vendor fix available
    Issue
    Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap use-after-free vulnerability in vtkGLTFDocumentLoader. The vulnerability manifests during mesh object copy operations where vector members are accessed after the underlying memory has been freed, specifically when handling GLTF files with corrupted or invalid mesh reference structures.

    Recommended action: Upgrade to 9.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. High, CVSS 7.1PyPIPublished

    PYSEC-2025-225

    CVE-2025-57107

    Affected
    • PyPI vtk < 9.5.1
    Fixed in
    9.5.1· Vendor fix available
    Issue
    Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader. When processing specially crafted GLTF files, the copy constructor of Accessor objects fails to properly validate buffer boundaries before performing memory read operations.

    Recommended action: Upgrade to 9.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  3. High, CVSS 7.5PyPIPublished

    PYSEC-2025-224

    CVE-2025-57106

    Affected
    • PyPI vtk < 9.5.1
    Fixed in
    9.5.1· Vendor fix available
    Issue
    Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.

    Recommended action: Upgrade to 9.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  4. High, CVSS 8.7PyPIAmendedPublished

    VTK NULL pointer dereference vulnerability

    CVE-2021-42521 · GHSA-xfhg-9pjg-xg7g

    Affected
    • PyPI vtk < 9.0.1
    Fixed in
    9.0.1· Vendor fix available
    Issue
    There is a NULL pointer dereference vulnerability in VTK, and it lies in IO/Infovis/vtkXMLTreeReader.cxx. The vendor didn't check the return value of libxml2 API 'xmlDocGetRootElement', and try to dereference it. It is unsafe as the return value can be NULL and that NULL pointer dereference may crash the application.

    Recommended action: Upgrade to 9.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →