Skip to content

← Public intelligence

PyPI package

vcspull

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    Command injection in libvcs and vcspull

    CVE-2022-21187 · GHSA-mv2w-4jqc-6fg4

    Affected
    • PyPI vcspull < 1.11.1
    Fixed in
    1.11.1· Vendor fix available
    Issue
    The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the updaterepo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.

    Recommended action: Upgrade to 1.11.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →