Skip to content

← Public intelligence

PyPI package

untangle

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    untangle vulnerable to XML Entity Expansion

    CVE-2022-33977 · GHSA-7xr3-6ggc-wc9p

    Affected
    • PyPI untangle < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    Impact An attacker may be able to cause a denial-of-service (DoS) condition on the server on which the product is running. This affects untangle versions up to and including 1.2.0 Patches The problem has been fixed with version 1.2.1 Workarounds None References https://jvn.jp/en/jp/JVN30454777/ For more information If you have any questions or comments about this advisory: Open an issue

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    untangle vulnerable to Improper Restriction of XML External Entity Reference

    CVE-2022-31471 · GHSA-f83q-2cp7-qrjg

    Affected
    • PyPI untangle < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts XML external entity references. By exploiting this vulnerability, a remote unauthenticated attacker may read the contents of local files. Impact An attacker may be able to read the contents of local files. This affects untangle versions up to and including 1.2.0 Patches The problem has been fixed with version 1.2.1 Workarounds None References https://jvn.jp/en/jp/JVN30454777/ For more information If you have any questions or comments about this advisory: Open an issue

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →