Critical, CVSS 9.8PyPIAmendedPublished
Salesforce Uni2TS has a Code Injection vulnerability
CVE-2026-22584 · GHSA-7x99-8x99-xc54
- Affected
- PyPI uni2ts <= 1.2.0
- Fixed in
- 2.0.0· Vendor fix available
- Issue
- Improper Control of Generation of Code ('Code Injection') vulnerability in Salesforce Uni2TS on MacOS, Windows, Linux allows Leverage Executable Code in Non-Executable Files.This issue affects Uni2TS: through 1.2.0.
Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.