Skip to content

← Public intelligence

PyPI package

trac

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

10 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Trac vulnerable to denial of service

    CVE-2008-5646 · GHSA-437p-qw95-wqqr

    Affected
    • PyPI trac < 0.11.2
    Fixed in
    0.11.2· Vendor fix available
    Issue
    Unspecified vulnerability in Trac before 0.11.2 allows attackers to cause a denial of service via unknown attack vectors related to "certain wiki markup."

    Recommended action: Upgrade to 0.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.1PyPIAmendedPublished

    Trac has vulnerability in HTML sanitizer filter

    CVE-2008-5647 · GHSA-ww53-wxxr-8f9w

    Affected
    • PyPI trac < 0.11.2
    Fixed in
    0.11.2· Vendor fix available
    Issue
    Unspecified vulnerability in the HTML sanitizer filter in Trac before 0.11.2 allows attackers to conduct phishing attacks via unknown attack vectors.

    Recommended action: Upgrade to 0.11.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    Trac is vulnerable to improper policy checks and missing 'raw' role check in docutils

    CVE-2009-4405 · GHSA-f9qv-j5g6-g5cr

    Affected
    • PyPI trac < 0.11.6
    Fixed in
    0.11.6· Vendor fix available
    Issue
    Multiple unspecified vulnerabilities in Trac before 0.11.6 have unknown impact and attack vectors, possibly related to (1) "policy checks in report results when using alternate formats" or (2) a "check for the 'raw' role that is missing in docutils < 0.6."

    Recommended action: Upgrade to 0.11.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.3PyPIAmendedPublished

    Trac Cross-site Scripting (XSS) vulnerability

    CVE-2008-3328 · GHSA-x6jf-c7wh-7m7w

    Affected
    • PyPI trac < 0.10.5
    Fixed in
    0.10.5· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the wiki engine in Trac before 0.10.5 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.

    Recommended action: Upgrade to 0.10.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 5.3PyPIAmendedPublished

    Trac Open Redirect vulnerability

    CVE-2008-2951 · GHSA-rcmj-xp8f-f6q4

    Affected
    • PyPI trac < 0.10.5
    Fixed in
    0.10.5· Vendor fix available
    Issue
    Open redirect vulnerability in the search script in Trac before 0.10.5 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the q parameter, possibly related to the quickjump function.

    Recommended action: Upgrade to 0.10.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 5.3PyPIAmendedPublished

    Trac Cross-site Scripting (XSS) vulnerability

    CVE-2007-1405 · GHSA-w7x2-57f7-3p3x

    Affected
    • PyPI trac < 0.10.3.1
    Fixed in
    0.10.3.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the "download wiki page as text" feature in Trac before 0.10.3.1, when Microsoft Internet Explorer is used, allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

    Recommended action: Upgrade to 0.10.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 6.9PyPIAmendedPublished

    Trac missing Content-Disposition HTTP header

    CVE-2007-1406 · GHSA-7jjr-3r8r-9pcf

    Affected
    • PyPI trac < 0.10.3.1
    Fixed in
    0.10.3.1· Vendor fix available
    Issue
    Trac before 0.10.3.1 does not send a Content-Disposition HTTP header specifying an attachment in certain "unsafe" situations, which has unknown impact and remote attack vectors.

    Recommended action: Upgrade to 0.10.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. High, CVSS 8.7PyPIAmendedPublished

    Edgewall Trac Cross-site request forgery (CSRF) vulnerability

    CVE-2006-5878 · GHSA-2q26-r8c4-jfx5

    Affected
    • PyPI trac < 0.10.1
    Fixed in
    0.10.1· Vendor fix available
    Issue
    Cross-site request forgery (CSRF) vulnerability in Edgewall Trac 0.10 and earlier allows remote attackers to perform unauthorized actions as other users via unknown vectors.

    Recommended action: Upgrade to 0.10.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  9. High, CVSS 8.8PyPIAmendedPublished

    Trac reStructuredText breach of privacy and denial of service vulnerability

    CVE-2006-3695 · GHSA-r524-c2gf-5chr

    Affected
    • PyPI trac < 0.9.6
    Fixed in
    0.9.6· Vendor fix available
    Issue
    Trac before 0.9.6 does not disable the "raw" or "include" commands when providing untrusted users with restructured text (reStructuredText) functionality from docutils, which allows remote attackers to read arbitrary files, perform cross-site scripting (XSS) attacks, or cause a denial of service via unspecified vectors. NOTE: this might be related to CVE-2006-3458.

    Recommended action: Upgrade to 0.9.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  10. Medium, CVSS 5.3PyPIAmendedPublished

    PYSEC-2005-1

    CVE-2005-4644 · GHSA-6vhp-hp77-6w52

    Affected
    • PyPI trac < 0.10
    Fixed in
    0.10· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the HTML WikiProcessor in Edgewall Trac 0.9.2 allows remote attackers to inject arbitrary web script or HTML via javascript in the SRC attribute of an IMG tag.

    Recommended action: Upgrade to 0.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →