Skip to content

← Public intelligence

PyPI package

svglib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    SVGlib Vulnerable to XXE Attacks

    CVE-2020-10799 · GHSA-3vcg-8p79-jpcv

    Affected
    • PyPI svglib <= 0.9.3
    Fixed in
    0.9.4· Vendor fix available
    Issue
    The svglib package through 0.9.3 for Python allows XXE attacks via an svg2rlg call.

    Recommended action: Upgrade to 0.9.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →