Skip to content

← Public intelligence

PyPI package

sqlfluff

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    SQLFluff: Uncontrolled Resource Consumption in SQLFluff Parser

    CVE-2026-46374 · GHSA-73jc-5mrq-prw7

    Affected
    • PyPI sqlfluff < 4.2.0
    Fixed in
    4.2.0· Vendor fix available
    Issue
    Impact In deployments where untrusted users can provide SQL queries to be linted, an untrusted user can submit a malicious long query to any application using the parser to trigger a Denial of Service through resource exhaustion. Patches Versions 4.2.0 and up contain a configurable parse node limit, which is enabled by default, to prevent this manner of exploit. Credit Ori Nakar from Imperva Threat Research Team.

    Recommended action: Upgrade to 4.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5PyPIAmendedPublished

    SQLFluff: Recursive Stack Overflow in Parser

    CVE-2026-46373 · GHSA-wmhf-fqc8-vxhh

    Affected
    • PyPI sqlfluff < 4.1.0
    Fixed in
    4.1.0· Vendor fix available
    Issue
    Impact In deployments where untrusted users can provide SQL queries to be linted, an untrusted user can submit a malicious query with deliberate excessive nesting to any application using the parser to trigger a Denial of Service through resource exhaustion. Patches Versions 4.1.0 and up contain a configurable recursion limit, which is enabled by default, to prevent this manner of exploit. Credit Ori Nakar from Imperva Threat Research Team.

    Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 4.8PyPIAmendedPublished

    SQLFluff users with access to config file, using libary_path may call arbitrary python code

    CVE-2023-36830 · GHSA-jqhc-m2j3-fjrx

    Affected
    • PyPI sqlfluff < 2.1.2
    Fixed in
    2.1.2· Vendor fix available
    Issue
    Impact In environments where untrusted users have access to the config files (e.g. .sqlfluff), there is a potential security vulnerability where those users could use the librarypath config value to allow arbitrary python code to be executed via macros. Jinja macros are executed within a sandboxed environment but the following example shows how an external url might be called and used to reveal internal information to an external listener: For many users who use SQLFluff in the context of an environment where all users already have fairly escalated privileges, this may not be an issue - however in larger user bases, or where SQLFluff is bundled into another tool where developers still wish to give users access to supply their on rule configuration, this may be an issue. Patches The 2.1.2 release offers the ability for the librarypath argument to be overwritten on the command line by using the --library-path option. This overrides any values provided in the config files and…

    Recommended action: Upgrade to 2.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →