Skip to content

← Public intelligence

PyPI package

sqlalchemy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    SQLAlchemy vulnerable to SQL injection

    CVE-2012-0805 · GHSA-hfg2-wf6j-x53p

    Affected
    • PyPI sqlalchemy < 0.7.0b4
    Fixed in
    0.7.0b4· Vendor fix available
    Issue
    Multiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select function, or unspecified vectors to the (3) select.limit or (4) select.offset function.

    Recommended action: Upgrade to 0.7.0b4 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    SQLAlchemy vulnerable to SQL Injection via order_by parameter

    CVE-2019-7164 · GHSA-887w-45rq-vxgf

    Affected
    • PyPI sqlalchemy < 1.3.0b3
    Fixed in
    1.3.0b3· Vendor fix available
    Issue
    SQLAlchemy before 1.3.0b3 allows SQL Injection via the orderby parameter. The fix (commit 30307c4) was applied only to the main branch and was never backported to the 1.2.x release line; all 1.2.x versions remain vulnerable.

    Recommended action: Upgrade to 1.3.0b3 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.3PyPIAmendedPublished

    SQLAlchemy is vulnerable to SQL Injection via group_by parameter

    CVE-2019-7548 · GHSA-38fc-9xqv-7f7q

    Affected
    • PyPI sqlalchemy < 1.2.19
    Fixed in
    1.2.19· Vendor fix available
    Issue
    SQLAlchemy 1.2.17 has SQL Injection when the groupby parameter can be controlled.

    Recommended action: Upgrade to 1.2.19 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →