Skip to content

← Public intelligence

PyPI package

rhodecode

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    RhodeCode and Kallithea are vulnerable to sensitive information disclosure

    CVE-2015-0260 · GHSA-hhx9-4vw2-x54r

    Affected
    • PyPI rhodecode < 2.2.7
    Fixed in
    2.2.7· Vendor fix available
    Issue
    RhodeCode before 2.2.7 and Kallithea 0.1 allows remote authenticated users to obtain API keys and other sensitive information via the getrepo API method.

    Recommended action: Upgrade to 2.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratedPyPIPublished

    PYSEC-2015-33

    CVE-2015-1613

    Affected
    • PyPI rhodecode < 2.2.7
    Fixed in
    2.2.7· Vendor fix available
    Issue
    RhodeCode before 2.2.7 allows remote authenticated users to obtain API keys and other sensitive information via the (1) update_repo, (2) get_locks, or (3) get_user_groups API method.

    Recommended action: Upgrade to 2.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →