Skip to content

← Public intelligence

PyPI package

reviewboard

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PyPIAmendedPublished

    Review Board Cross-site scripting (XSS) vulnerability in the reviews dropdown

    CVE-2013-2209 · GHSA-6g7x-4c7m-g63m

    Affected
    • PyPI reviewboard >= 1.6, < 1.6.17; >= 1.7, < 1.7.10
    Fixed in
    1.6.171.7.10· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the auto-complete widget in htdocs/media/rb/js/reviews.js in Review Board 1.6.x before 1.6.17 and 1.7.x before 1.7.10 allows remote attackers to inject arbitrary web script or HTML via a full name.

    Recommended action: Upgrade to 1.7.10 or 1.6.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    ReviewBoard and Djblets library are vulnerable to code execution

    CVE-2013-4409 · GHSA-58h8-44mg-r43x

    Affected
    • PyPI reviewboard < 1.7.15
    Fixed in
    1.7.15· Vendor fix available
    Issue
    An eval() vulnerability exists in Python Software Foundation Djblets version before 0.6.30 and 0.7.0 before 0.7.19 and Beanbag Review Board before 1.7.15 when parsing JSON requests allowing an attacker to execute arbitrary Python code.

    Recommended action: Upgrade to 1.7.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →