Skip to content

← Public intelligence

PyPI package

radicale

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0PyPIAmendedPublished

    Radicale is vulnerable to directory traversal on Windows Filesystem Storage Backend component

    CVE-2016-1505 · GHSA-84cw-mxhv-qvv4

    Affected
    • PyPI radicale < 1.1
    Fixed in
    1.1· Vendor fix available
    Issue
    The filesystem storage backend in Radicale before 1.1 on Windows allows remote attackers to read or write to arbitrary files via a crafted path, as demonstrated by /c:/file/ignore.

    Recommended action: Upgrade to 1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Radicale regex metacharacters injection in the user name

    CVE-2015-8748 · GHSA-6w8c-6jrg-qwj2

    Affected
    • PyPI radicale < 1.1
    Fixed in
    1.1· Vendor fix available
    Issue
    Radicale before 1.1 allows remote authenticated users to bypass ownerwrite and owneronly limitations via regex metacharacters in the user name, as demonstrated by ..

    Recommended action: Upgrade to 1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 10.0PyPIAmendedPublished

    Radicale vulnerable to arbitrary file read or write

    CVE-2015-8747 · GHSA-fgqv-96v9-w23m

    Affected
    • PyPI radicale < 1.1
    Fixed in
    1.1· Vendor fix available
    Issue
    The multifilesystem storage backend in Radicale before 1.1 allows remote attackers to read or write to arbitrary files via a crafted component name.

    Recommended action: Upgrade to 1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.1PyPIAmendedPublished

    Radicale is vulnerable to timing oracles and simple bruteforce attacks

    CVE-2017-8342 · GHSA-rpv4-63g3-9x23

    Affected
    • PyPI radicale < 1.1.2; >= 2.0.0rc1, <= 2.0.0rc1
    Fixed in
    1.1.22.0.0rc2· Vendor fix available
    Issue
    Radicale before 1.1.2 and 2.0.0rc1 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

    Recommended action: Upgrade to 2.0.0rc2 (pre-release) or 1.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →