Skip to content

← Public intelligence

PyPI package

python-saml

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.3PyPIAmendedPublished

    Python-saml allows manipulation of SAML data without invalidation of cryptographic signature

    CVE-2017-11427 · GHSA-j8j8-348v-wfm3

    Affected
    • PyPI python-saml < 2.4.0
    Fixed in
    2.4.0· Vendor fix available
    Issue
    OneLogin PythonSAML 2.3.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

    Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →