Critical, CVSS 9.3PyPIAmendedPublished
OpenStack Murano Code Execution
CVE-2016-4972 · GHSA-87r7-q54j-f9qg
- Affected
- PyPI python-muranoclient < 0.7.3; >= 0.8.0, < 0.8.5
- Fixed in
- 0.7.30.8.5· Vendor fix available
- Issue
- OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka) improperly use loaders inherited from yaml.Loader when parsing MuranoPL and UI files, which allows remote attackers to create arbitrary Python objects and execute arbitrary code via crafted extended YAML tags in UI definitions in packages.
Recommended action: Upgrade to 0.8.5 or 0.7.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.