Skip to content

← Public intelligence

PyPI package

python-a2a

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PyPIAmendedPublished

    python-a2a has a path traversal in the create_workflow function

    CVE-2025-6167 · GHSA-rp38-pj7h-r8q2

    Affected
    • PyPI python-a2a < 0.5.6
    Fixed in
    0.5.6· Vendor fix available
    Issue
    A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function createworkflow of the file pythona2a/agentflow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.

    Recommended action: Upgrade to 0.5.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →