Skip to content

← Public intelligence

PyPI package

pyrad

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2PyPIAmendedPublished

    pyrad is vulnerable to the use of Insufficiently Random Values

    CVE-2013-0294 · GHSA-q4v3-wmm6-hcrx

    Affected
    • PyPI pyrad < 2.1
    Fixed in
    2.1· Vendor fix available
    Issue
    packet.py in pyrad before 2.1 uses weak random numbers to generate RADIUS authenticators and hash passwords, which makes it easier for remote attackers to obtain sensitive information via a brute force attack.

    Recommended action: Upgrade to 2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    pyrad uses sequential packet IDs

    CVE-2013-0342 · GHSA-w4px-9pgm-p2f3

    Affected
    • PyPI pyrad < 2.1
    Fixed in
    2.1· Vendor fix available
    Issue
    The CreateID function in packet.py in pyrad before 2.1 uses sequential packet IDs, which makes it easier for remote attackers to spoof packets by predicting the next ID, a different vulnerability than CVE-2013-0294.

    Recommended action: Upgrade to 2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →