Skip to content

← Public intelligence

PyPI package

pyopenssl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.2PyPIAmendedPublished

    pyOpenSSL DTLS cookie callback buffer overflow

    CVE-2026-27459 · GHSA-5pwr-322w-8jr4

    Affected
    • PyPI pyopenssl >= 22.0.0, < 26.0.0
    Fixed in
    26.0.0· Vendor fix available
    Issue
    If a user provided callback to setcookiegeneratecallback returned a cookie value greater than 256 bytes, pyOpenSSL would overflow an OpenSSL provided buffer. Cookie values that are too long are now rejected.

    Recommended action: Upgrade to 26.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Low, CVSS 1.7PyPIAmendedPublished

    pyOpenSSL allows TLS connection bypass via unhandled callback exception in set_tlsext_servername_callback

    CVE-2026-27448 · GHSA-vp96-hxj8-p424

    Affected
    • PyPI pyopenssl >= 0.14.0, < 26.0.0
    Fixed in
    26.0.0· Vendor fix available
    Issue
    If a user provided callback to settlsextservernamecallback raised an unhandled exception, this would result in a connection being accepted. If a user was relying on this callback for any security-sensitive behavior, this could allow bypassing it. Unhandled exceptions now result in rejecting the connection. Credit to Leury Castillo for reporting this issue.

    Recommended action: Upgrade to 26.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    PyOpenSSL Mishandles NUL Byte In Certificate Subject Alternative Name

    CVE-2013-4314 · GHSA-6748-36qp-fx6r

    Affected
    • PyPI pyopenssl < 0.13.1
    Fixed in
    0.13.1· Vendor fix available
    Issue
    The X509Extension in pyOpenSSL before 0.13.1 does not properly handle a \0 character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

    Recommended action: Upgrade to 0.13.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.1PyPIAmendedPublished

    PyOpenSSL Use-After-Free vulnerability

    CVE-2018-1000807 · GHSA-p28m-34f6-967q

    Affected
    • PyPI pyopenssl < 17.5.0
    Fixed in
    17.5.0· Vendor fix available
    Issue
    It was discovered that pyOpenSSL incorrectly handled memory when handling X509 objects. A remote attacker could use this issue to cause pyOpenSSL to crash, resulting in a denial of service, or possibly execute arbitrary code. This attack appears to be exploitable via Depends on the calling application and if it retains a reference to the memory. This vulnerability appears to have been fixed in 17.5.0.

    Recommended action: Upgrade to 17.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 8.2PyPIAmendedPublished

    Pyopenssl Incorrect Memory Management

    CVE-2018-1000808 · GHSA-2rcm-phc9-3945

    Affected
    • PyPI pyopenssl < 17.5.0
    Fixed in
    17.5.0· Vendor fix available
    Issue
    It was discovered that pyOpenSSL incorrectly handled memory when performing operations on a PKCS #12 store. A remote attacker could possibly use this issue to cause pyOpenSSL to consume resources, resulting in a denial of service. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection that would cause the calling application to reload certificates from a PKCS #12 store. This vulnerability appears to have been fixed in 17.5.0.

    Recommended action: Upgrade to 17.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →