Medium, CVSS 5.3PyPIAmendedPublished
PyOD persistence.load deserializes untrusted artifacts before validation
CVE-2026-15529 · GHSA-997v-r4v7-9f3g
- Affected
- PyPI pyod >= 3.5.0, < 3.6.2
- Fixed in
- 3.6.2· Vendor fix available
- Issue
- A vulnerability was detected in yzhao062 pyod 3.5.0/3.5.1/3.5.2. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. The pull request to fix this issue requires some minor changes.
Recommended action: Upgrade to 3.6.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.