Skip to content

← Public intelligence

PyPI package

pyo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    Classic Buffer Overflow in pyo

    CVE-2021-41499 · GHSA-5f5c-687x-g5qm

    Affected
    • PyPI pyo < 1.0.3
    Fixed in
    1.0.3· Vendor fix available
    Issue
    Buffer Overflow Vulnerability exists in ajaxsoundstudio.com in Pyo < 1.03 in the Serverdebug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.

    Recommended action: Upgrade to 1.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    Pyo Buffer Overflow Vulnerability

    CVE-2021-41498 · GHSA-qj27-32wp-ghrg

    Affected
    • PyPI pyo < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Buffer overflow in ajaxsoundstudio.com Pyo <= 1.03 in the Serverjackinit function which allows attackers to conduct Denial of Service attacks by arbitrary constructing a overlong clientname.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →