Skip to content

← Public intelligence

PyPI package

pymysql

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PyPIAmendedPublished

    PyMySQL SQL Injection vulnerability

    CVE-2024-36039 · GHSA-v9hf-5j83-6xpp

    Affected
    • PyPI pymysql < 1.1.1
    Fixed in
    1.1.1· Vendor fix available
    Issue
    PyMySQL through 1.1.0 allows SQL injection if used with untrusted JSON input because keys are not escaped by escapedict.

    Recommended action: Upgrade to 1.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →