UnratedPyPIPublished
PYSEC-2022-220
CVE-2022-30885
- Affected
- PyPI pyesasky >= 1.2.0, < 1.4.3
- Fixed in
- 1.4.3· Vendor fix available
- Issue
- Reserved The pyesasky for python, as distributed on PyPI, included a code-execution backdoor inserted by a third party. The current version, without this backdoor, is 1.2.0-1.4.2.
Recommended action: Upgrade to 1.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.