Skip to content

← Public intelligence

PyPI package

pycryptodome

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    PyCryptodome and pycryptodomex side-channel leakage for OAEP decryption

    CVE-2023-52323 · GHSA-j225-cvw7-qrx7

    Affected
    • PyPI pycryptodome < 3.19.1
    Fixed in
    3.19.1· Vendor fix available
    Issue
    PyCryptodome and pycryptodomex before 3.19.1 allow side-channel leakage for OAEP decryption, exploitable for a Manger attack.

    Recommended action: Upgrade to 3.19.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    PyCryptodome integer overflow vulnerability

    CVE-2018-15560 · GHSA-hgg3-g7gr-66r7

    Affected
    • PyPI pycryptodome < 3.6.6
    Fixed in
    3.6.6· Vendor fix available
    Issue
    PyCryptodome before 3.6.6 has an integer overflow in the datalen variable in AESNI.c, related to the AESNIencrypt and AESNIdecrypt functions, leading to the mishandling of messages shorter than 16 bytes.

    Recommended action: Upgrade to 3.6.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →