Skip to content

← Public intelligence

PyPI package

plone-rest

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.6PyPIAmendedPublished

    plone.rest vulnerable to Denial of Service when ++api++ is used many times

    CVE-2023-42457 · GHSA-h6rp-mprm-xgcq

    Affected
    • PyPI plone-rest >= 2.0.0a1, < 2.0.1; >= 3.0.0, <= 3.0.0
    Fixed in
    2.0.13.0.1· Vendor fix available
    Issue
    Impact When the ++api++ traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive. Patches Patches will be released in plone.rest 2.0.1 and 3.0.1. Series 1.x is not affected. Workarounds In your frontend web server (nginx, Apache) you can redirect /++api++/++api++ to /++api++.

    Recommended action: Upgrade to 3.0.1 or 2.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →