Critical, CVSS 9.3PyPIAmendedPublished
pipreqs vulnerable to Dependency Confusion
CVE-2023-31543 · GHSA-v4f4-23wc-99mh
- Affected
- PyPI pipreqs >= 0.3.0, < 0.4.12
- Fixed in
- 0.4.12· Vendor fix available
- Issue
- A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.
Recommended action: Upgrade to 0.4.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.