Skip to content

← Public intelligence

PyPI package

pikepdf

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Improper Restriction of XML External Entity Reference in pikepdf

    CVE-2021-29421 · GHSA-ccgm-3xw4-h5p8

    Affected
    • PyPI pikepdf >= 1.3.0, < 2.10.0
    Fixed in
    2.10.0· Vendor fix available
    Issue
    models/metadata.py in the pikepdf package 1.3.0 through 2.9.2 for Python allows XXE when parsing XMP metadata entries.

    Recommended action: Upgrade to 2.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →