Skip to content

← Public intelligence

PyPI package

pglast

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1PyPIAmendedPublished

    libpg_query memory leak

    CVE-2018-18482 · GHSA-vm3q-58wm-2r2x

    Affected
    • PyPI pglast < 0.28
    Fixed in
    0.28· Vendor fix available
    Issue
    An issue was discovered in libpgquery 10-1.0.2. There is a memory leak in pgqueryrawparse in pgqueryparse.c, which might lead to a denial of service.

    Recommended action: Upgrade to 0.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →