High, CVSS 8.1PyPIAmendedPublished
pg8000 SQL injection vulnerability via a specially crafted Python list input
CVE-2025-61385 · GHSA-wq2g-r956-j8cc
- Affected
- PyPI pg8000 <= 1.31.4
- Fixed in
- 1.31.5· Vendor fix available
- Issue
- SQL injection vulnerability in tlocke pg8000 1.31.4 allows remote attackers to execute arbitrary SQL commands via a specially crafted Python list input to function pg8000.native.literal.
Recommended action: Upgrade to 1.31.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.