High, CVSS 7.1PyPIAmendedPublished
libpg_query memory leak
CVE-2018-18482 · GHSA-vm3q-58wm-2r2x
- Affected
- PyPI pg-query < 0.28
- Fixed in
- 0.28· Vendor fix available
- Issue
- An issue was discovered in libpgquery 10-1.0.2. There is a memory leak in pgqueryrawparse in pgqueryparse.c, which might lead to a denial of service.
Recommended action: Upgrade to 0.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.