Skip to content

← Public intelligence

PyPI package

personnummer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIAmendedPublished

    personnummer/python vulnerable to Improper Input Validation

    GHSA-rxq3-5249-8hgg

    Affected
    • PyPI personnummer < 3.0.2
    Fixed in
    3.0.2· Vendor fix available
    Issue
    This vulnerability was reported to the personnummer team in June 2020. The slow response was due to locked ownership of some of the affected packages, which caused delays to update packages prior to disclosure. The vulnerability is determined to be low severity. Impact This vulnerability impacts users who rely on the for last digits of personnummer to be a real personnummer. Patches The issue have been patched in all repositories. The following versions should be updated to as soon as possible: C 3.0.2 D 3.0.1 Dart 3.0.3 Elixir 3.0.0 Go 3.0.1 Java 3.3.0 JavaScript 3.1.0 Kotlin 1.1.0 Lua 3.0.1 PHP 3.0.2 Perl 3.0.0 Python 3.0.2 Ruby 3.0.1 Rust 3.0.0 Scala 3.0.1 Swift 1.0.1 If you are using any of the earlier packages, please update to latest. Workarounds The issue arrieses from the regular expression allowing the first three digits in the last four digits of the personnummer to be 000, which is invalid. To mitigate this without upgrading, a check on the last four digits can be made to…

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →