Skip to content

← Public intelligence

PyPI package

paste

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code

    CVE-2010-2477 · GHSA-7gfc-2v6g-6w9f

    Affected
    • PyPI paste < 1.7.4
    Fixed in
    1.7.4· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in the paste.httpexceptions implementation in Paste before 1.7.4 allow remote attackers to inject arbitrary web script or HTML via vectors involving a 404 status code, related to (1) paste.urlparser.StaticURLParser, (2) paste.urlparser.PkgResourcesParser, (3) paste.urlmap.URLMap, and (4) HTTPNotFound.

    Recommended action: Upgrade to 1.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.1PyPIAmendedPublished

    Paste Script has improper group memberships permissions

    CVE-2012-0878 · GHSA-27px-qpmj-qg38

    Affected
    • PyPI paste < 1.7.5.1
    Fixed in
    1.7.5.1· Vendor fix available
    Issue
    Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.

    Recommended action: Upgrade to 1.7.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →