Skip to content

← Public intelligence

PyPI package

paddlepaddle

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

27 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1PyPIAmendedPublished

    PaddlePaddle Out-of-bounds Read vulnerability

    CVE-2022-46741 · GHSA-2hvc-hwg3-hpvw

    Affected
    • PyPI paddlepaddle < 2.4
    Fixed in
    2.4· Vendor fix available
    Issue
    Out-of-bounds read in gathertree in PaddlePaddle before 2.4. A patch is available in the release/2.4 branch.

    Recommended action: Upgrade to 2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8PyPIAmendedPublished

    PaddlePaddle vulnerable to code injection via winstr

    CVE-2022-45908 · GHSA-83g7-8fch-p37m

    Affected
    • PyPI paddlepaddle < 2.4
    Fixed in
    2.4· Vendor fix available
    Issue
    In PaddlePaddle before 2.4, paddle.audio.functional.getwindow is vulnerable to code injection because it calls eval on a user-supplied winstr. This may lead to arbitrary code execution.

    Recommended action: Upgrade to 2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →