Skip to content

← Public intelligence

PyPI package

orjson

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7PyPIAmendedPublished

    orjson does not limit recursion for deeply nested JSON documents

    CVE-2025-67221 · GHSA-hx9q-6w63-j58v

    Affected
    • PyPI orjson < 3.11.6
    Fixed in
    3.11.6· Vendor fix available
    Issue
    The orjson.dumps function in orjson before 3.11.6 does not limit recursion for deeply nested JSON documents.

    Recommended action: Upgrade to 3.11.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5PyPIAmendedPublished

    orjson does not limit recursion for deeply nested JSON documents

    CVE-2024-27454 · GHSA-pwr2-4v36-6qpr

    Affected
    • PyPI orjson < 3.9.15
    Fixed in
    3.9.15· Vendor fix available
    Issue
    orjson.loads in orjson before 3.9.15 does not limit recursion for deeply nested JSON documents.

    Recommended action: Upgrade to 3.9.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →