Critical, CVSS 9.3PyPIAmendedPublished
Ops CLI Deserialization of Untrusted Data vulnerability
CVE-2021-40720 · GHSA-x23q-4j9j-9cxw
- Affected
- PyPI ops-cli <= 2.0.4
- Fixed in
- 2.0.5· Vendor fix available
- Issue
- Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkoutrepo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Recommended action: Upgrade to 2.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.