Critical, CVSS 9.9PyPIPublished
PYSEC-2026-2246
CVE-2026-27941 · GHSA-9jgv-x8cq-296q
- Affected
- PyPI openlit >= 1.36.2, < 1.37.1
- Fixed in
- 1.37.1· Vendor fix available
- Issue
- OpenLIT is an open source platform for AI engineering. Prior to version 1.37.1, several GitHub Actions workflows in OpenLIT's GitHub repository use the `pull_request_target` event while checking out and executing untrusted code from forked pull requests. These workflows run with the security context of the base repository, including a write-privileged `GITHUB_TOKEN` and numerous sensitive secrets (API keys, database/vector store tokens, and a Google Cloud service account key). Version 1.37.1 contains a fix.
Recommended action: Upgrade to 1.37.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.