Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Amphora Images in OpenStack Octavia =0.10.0 <2.1.2, =3.0.0 <3.2.0, =4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the cmd/agent.py gunicorn certreqs option is True but is supposed to be ssl.CERTREQUIRED.
Recommended action: Upgrade to 4.1.0, 3.2.0 or 2.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
An access-control flaw was found in the Octavia service when the cloud platform was deployed using Red Hat OpenStack Platform Director. An attacker could cause new amphorae to run based on any arbitrary image. This meant that a remote attacker could upload a new amphorae image and, if requested to spawn new amphorae, Octavia would then pick up the compromised image. Mitigation To prevent this vulnerability: 1. Update Octavia's configuration setting (octavia.conf) to ampimageownerid = $UUIDOFSERVICEPROJECT on all Octavia nodes. 2. Enable the new configuration by restarting both octaviaworker and octaviahealthmanager.
Recommended action: Upgrade to 0.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In a default Red Hat Openstack Platform Director installation, openstack-octavia before versions openstack-octavia 2.0.2-5 and openstack-octavia-3.0.1-0.20181009115732 creates log files that are readable by all users. Sensitive information such as private keys can appear in these log files allowing for information exposure.
Recommended action: Upgrade to 3.1.0 or 2.1.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.