High, CVSS 8.8PyPIAmendedPublished
NI MeasurementLink Python Services Improper Access Restriction vulnerability
CVE-2023-4570 · GHSA-3f48-9j7q-q2gv
- Affected
- PyPI ni-measurementlink-service < 1.1.1; >= 1.2.0.dev0, < 1.2.0
- Fixed in
- 1.2.01.1.1· Vendor fix available
- Issue
- Impact An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions. Patches Upgrade all Python measurement plug-ins to use ni-measurementlink-service version 1.1.1 or later. References Visit ni.com/info and enter the info code cve-2023-4570 for more information.
Recommended action: Upgrade to 1.2.0 or 1.1.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.