High, CVSS 8.7PyPIAmendedPublished
Code injection in nbgitpuller
CVE-2021-39160 · GHSA-mq5p-2mcr-m52j
- Affected
- PyPI nbgitpuller >= 0.9.0, <= 0.10.1
- Fixed in
- 0.10.2· Vendor fix available
- Issue
- Impact Due to an unsanitized input, visiting maliciously crafted links could result in arbitrary code execution in the user environment. Patches 0.10.2 Workarounds None, other than upgrade to 0.10.2 or downgrade to 0.8.x. For more information If you have any questions or comments about this advisory: Open an issue in nbgitpuller Email our security team at security@ipython.org
Recommended action: Upgrade to 0.10.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.