Critical, CVSS 9.3PyPIAmendedPublished
Nameko Arbitrary code execution due to YAML deserialization
CVE-2021-41078 · GHSA-6p52-jr3q-c94g
- Affected
- PyPI nameko < 2.14.0; >= 3.0.0rc0, <= 3.0.0rc9
- Fixed in
- 3.0.0rc102.14.0· Vendor fix available
- Issue
- Impact Nameko can be tricked to perform arbitrary code execution when deserialising a YAML config file. Example: Patches The problem was fixed in https://github.com/nameko/nameko/pull/722 and released in version 2.14.0, and in rc10 of the v3 pre-release. Versions prior to 2.14.0, and v3.0.0rc0 through v3.0.0rc9 are still vulnerable. Workarounds The vulnerability is exploited by config files with malicious content. It can be avoided by only using config files that you trust.
Recommended action: Upgrade to 3.0.0rc10 (pre-release) or 2.14.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.