High, CVSS 7.3PyPIAmendedPublished
ModelScope is vulnerable to arbitrary code injection via a crafted module
CVE-2025-51427 · GHSA-fhhq-h4hg-549x
- Affected
- PyPI modelscope < 1.27.0
- Fixed in
- 1.27.0· Vendor fix available
- Issue
- An issue was discovered in ModelScope 1.25.0 allowing attackers to execute arbitrary code via crafted module listed in the configuration file (deymini.yaml) under the key ['nnet']['module'].
Recommended action: Upgrade to 1.27.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.